股票吧

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 20835|回复: 7

[其他] 超强MACD优化指标公式

[复制链接]
发表于 2015-11-19 10:29 | 显示全部楼层 |阅读模式
  这个公式它看似普通,会用的话就不普通了.它里面能找到的买卖信号不少.如:低位金叉,二次金叉,零下二次金叉, 底背离,顶背离,建仓,加仓,破仓,绿柱消失买入,红柱消失卖出,以及死叉卖出.希望对大家适用。
  DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);
  DEA:EMA(DIFF,9);
  MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;
  低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
  STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;
  DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;
  JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
  二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
  STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;
  DRAWICON(二次金叉,DEA*0.9,1) ;
  DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;
  A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
  底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
  STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
  底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2;
  DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;
  A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
  顶背离:=REF(CLOSE,A2+1)DIFF AND CROSS(DEA,DIFF);
  顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK2;
  DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.25,'三全项'),COLOR0000FF,LINETHICK2;
  建仓:IF(DIFF<0,DIFF,0),COLORYELLOW,LINETHICK2;
  加仓:IF(DIFF<0,0,DIFF),COLORRED,LINETHICK2;
  破仓:IF(DIFF
  趋势强弱:IF(DIFF>DEA,DEA,DEA),COLORFF937F,LINETHICK2;
  绿柱消失买入:STICKLINE(DIFF<0,0,DIFF,0.5,0),COLOR009700;
  红柱消失卖出:STICKLINE(DIFF>=0,0,DIFF,0.5,0),COLORRED;
  STICKLINE(DEA>=0,0,DEA,0,0),COLORBLUE;
  STICKLINE(DEA<0,0,DEA,0,0),COLORYELLOW;
  DRAWICON(CROSS(DIFF,DEA),DEA*1.1,1);
  DRAWICON(CROSS(DEA,DIFF),DEA*1.1,2);

结合更多指标精准捕捉牛股!.zip (1.08 KB, 下载次数: 153)
 楼主| 发表于 2015-11-20 09:28 | 显示全部楼层
今日市场将迎来期指1511合约的交割。通观昨日期现两市的走势,两市之间基差的贴水现象已经完全消失,基差恢复升水。这样的状况将有利于于今日期指的平稳交割。期指的平稳交割将有利于今日市场走势的平稳。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-12-3 09:34 | 显示全部楼层
为何大金融板块会出现如此凌厉涨势,一个绕不开的成因就是人民币加入SDR。根据券商研报显示,人民币加入SDR意味着人民币国际化进程已经成为现实,这将从三个逻辑推动以银行股为首的大金融板块行情。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2016-2-18 10:57 | 显示全部楼层
目前资金线是否真正的找到历史底部,还需要进一步观察。昨日小编指出,如果资金线要见到历史大底,需要满足2个条件:第一需要资金线跌到位,第二需要通过成交量放出巨量来检验。
回复 支持 反对

使用道具 举报

发表于 2016-4-25 15:49 | 显示全部楼层
加油~!学习了~!每日学习一点点~!生活更精彩~!
回复 支持 反对

使用道具 举报

发表于 2016-5-5 16:28 | 显示全部楼层
谢谢分享,谢谢谢谢
回复 支持 反对

使用道具 举报

发表于 2016-5-6 13:15 | 显示全部楼层
受益无穷,谢谢
回复 支持 反对

使用道具 举报

发表于 2016-8-8 17:55 | 显示全部楼层
加油~!学习了~!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

广告联系|Archiver|手机版|股票吧 ( 粤ICP备05036799号 )

GMT+8, 2017-6-27 08:14 , Processed in 0.105300 second(s), 22 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表