股票吧

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 3237|回复: 4

[其他] 取材有道新年送通达信.大智慧.抓次日马上涨停主图及选股指标公式源码

[复制链接]
发表于 2014-1-31 20:01 | 显示全部楼层 |阅读模式
本帖最后由 取财有道 于 2014-2-1 18:22 编辑

截图02.jpg
截图03.jpg
投资者都想要抓涨停板,但往往又是不得要领,究其原因就是没有掌握抓涨停技巧的精髓,本文为大家介绍的次日涨停公式就能够满足投资者的需求,帮助大家抓住涨停,投资获利。下面就为朋友们总结次日涨停公式的源代码,希望朋友们能够从中获得抓住涨停板的技巧,掌握这一公式的精髓一定能给大家带来不小的收获。
FILLRGN((J >= A2),A2,J),colorFF;
FILLRGN((J <= A2),J,A2),colorFF00;
压力:HHV(J,60),colorFFFF;
支撑:=LLV(AA,13);
STICKLINE((((J <= 中期大底) AND ((上上 - REF(上上,1)) > 0)) AND (CLOSE >= (OPEN * 0.99))),1,88,3,0),colorFF00;
DRAWICON((((J <= 中期大底) AND ((上上 - REF(上上,1)) > 0)) AND (CLOSE >= (OPEN * 0.99))),88,0);
DRAWTEXT((((J <= 中期大底) AND ((上上 - REF(上上,1)) > 0)) AND (CLOSE >= (OPEN * 0.99))),85,'-');
STICKLINE(FILTER((CROSS(上,中期大底) AND ((上上 - REF(上上,1)) >= 0)),3),中期大底,70,3,0),colorFF;
DRAWICON(FILTER((CROSS(上,中期大底) AND ((上上 - REF(上上,1)) >= 0)),3),70,0);
DRAWTEXT(FILTER((CROSS(上,中期大底) AND ((上上 - REF(上上,1)) >= 0)),3),64,'-买了次日涨停'),colorFFFFFF;
STICKLINE((CROSS(上,下) AND (CLOSE >= OPEN)),中期大底,60,2,0),colorFF0000;
DRAWICON((CROSS(上,下) AND (CLOSE >= OPEN)),60,0);
DRAWTEXT((CROSS(上,下) AND (CLOSE >= OPEN)),55,'-短线');
 楼主| 发表于 2014-2-1 09:58 | 显示全部楼层
本帖最后由 取财有道 于 2014-2-1 10:06 编辑

次日涨停指标源码 主图及选股指标[大智慧公式]

次日涨停股选股公式源码:

A :=MA(CLOSE,26);
UP:=A + 2*STD(CLOSE,26);
LOWER:= A - 2*STD(CLOSE,26);
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,ref(C,W2),ref(C,W2));
W4:=CROSS(C,ref(W3,1));
XG: W4 AND COUNT(W4,5)=1;



主图次日涨停指标
A : MA(CLOSE,26);
UP: A + 2*STD(CLOSE,26);
LOWER: A - 2*STD(CLOSE,26);
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
CXH:=STRTONUM(STRRIGHT(DATESTR(CURRENTDATE),1));
WARNING('http://www.cxh99.com',CURRENTTIME>180000 and (CXH=2 OR CXH=7));
DRAWTEXTREL(10 ,10 ,'');
W3:=IF(W2>0,ref(C,W2),ref(C,W2));
W4:=CROSS(C,ref(W3,1));
DRAWICON(W4 AND COUNT(W4,5)=1,LOW,3);
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-2-1 10:15 | 显示全部楼层
本帖最后由 取财有道 于 2014-2-1 10:49 编辑

通达信抓涨停指标公式

N:=12;M:=6;W:=1;
PSY:COUNT(CLOSE>REF(CLOSE,1),N)/N*100;
PSYMA:MA(PSY,M);
50,COLORLIGREEN,LINETHICK4,POINTDOT;
V11:=MA(C,3)=LLV(MA(C,3),7);
V12:=MA(C,3)<MA(C,5);
V13:=MA(V,5)<MA(V,10)*0.99;
V14:=COUNT(MA(C,1)<REF(C,1),2)=2;
买:IF(V11 AND V12 AND V13 AND V14,80,40),COLORBLUE,LINETHICK2;DRAWTEXT_FIX(C>O,0.01,0.9,0,'WWW.CXH99.COM'),COLORRED;
截图02.jpg
回复 支持 反对

使用道具 举报

 楼主| 发表于 2014-2-1 10:56 | 显示全部楼层
本帖最后由 取财有道 于 2014-2-1 10:59 编辑

自编强势股选股公式

公式编写与应用选出一个星期之内(5个交易日内)涨停板的公式。
  每个星期六,星期天都把上个星期出现过的涨停板的股票看几遍,思考一下为什么会出现涨停板。
  相信很多朋友也有这样的想法,但有一个问题却让大家觉得很麻烦。就是怎么样去记出现过涨停板的股票呢?有这样的问题就大家要动脑筋了。使用的是让电脑自己来选出一个星期出现过涨停板的股票,根本不用记的。想看的时候让电脑帮一下忙选一下就行了。

  公式里已经除掉了ST股票和新股上市第一天的大涨幅。
  同花顺公式如下:
ztb1:=C/C[1]>1.095  AND C/C[1]<1.11;
ztb:=COUNT(ztb1,5)>0;
ztb
  通达信公式如下:
ZTB1:=C/REF(C,1)>1.095  AND C/REF(C,1)<1.11;
ZTB:=COUNT(ZTB1,5)>0;
ZTB
  有兴趣的朋友可以试一下,看看效果如何?欢迎交流心得。

走势特征选股-------突然放量
参数:N,       1.00,   300.00,     10.00;
      M,      1.00,   40.00,        3.00;
VOL>REF(HHV(VOL,N),1)*M;

通达信 均线实用的选股 指标源码

1、四合一金叉选股公式
一个5日均线金叉10日均线,成交量5日均量金叉10日均量,MACD金叉,KDJ金叉,上面四个条件满足三个同时金叉就可以成立的选股公式:
M1:=MA(CLOSE,5);
M2:=MA(CLOSE,10);
MA1:=MA(VOL,5);
MA2:=MA(VOL,10);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
A1:=DEA;
F1:=DIF;
K1:="KDJ.K";
J1:="KDJ.J";
金叉1:=CROSS(M1,M2);
金叉2:=CROSS(MA1,MA2);
金叉3:=CROSS(F1,A1);
金叉4:=CROSS(J1,K1);
选1:=金叉1 AND 金叉2 AND 金叉3 AND 金叉4;
选2:=金叉1 AND 金叉2 AND 金叉3;
选3:=金叉2 AND 金叉3 AND 金叉4;
选4:=金叉1 AND 金叉2 AND 金叉4;
选5:=金叉1 AND 金叉3 AND 金叉4;
选股:选1 OR 选2 OR 选3 OR 选4 OR 选5;

条件选股公式应用
1)“公式管理”----点选左侧“条件选股”-----点“新建”----取个名字--------把代码粘贴进去-------在软件编辑界面点“属性”选择“禁用周期”除了“分笔成交”之外,其余的全部勾选,保存文件。
2)设置预警 “工具”-----“系统预警”---新增条件---在左侧“条件选股”里面选择刚才的公式,然后选择监控的板块-发出声音--预警后保持监控---等设置,完毕了.
回复 支持 反对

使用道具 举报

发表于 2018-1-10 15:39 | 显示全部楼层
感谢分享!!!!!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

广告联系|Archiver|手机版|股票吧 ( 粤ICP备05036799号 )

GMT+8, 2018-10-21 05:50 , Processed in 0.088699 second(s), 26 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表