股票吧

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 2546|回复: 1

[同花顺] 主图彩色布林 适合主升浪选手

[复制链接]
发表于 2013-5-21 11:21 | 显示全部楼层 |阅读模式
指标介绍:

主图彩色布林线 一目了然 适合追主升浪 有兴趣的不妨试试

公式源码:

二分位:(H+L)/2 ,LINETHICK3,coloryellow,POINTDOT;
MID1 : MA(CLOSE,18),POINTDOT,LINETHICK3,colorwhite;
UPPER1: MID1 + 2*STD(CLOSE,14),linethick2,coloryellow;
LOWER1: MID1 - 2*STD(CLOSE,14),linethick2,coloryellow;
VAR1:=UPPER1;
FF:=VAR1>REF(VAR1,1);
PARTLINE(VAR1,FF,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK4;
VAR2:=LOWER1;
FF:=VAR2>REF(VAR2,1); PARTLINE(VAR2,FF,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK4;
VAR3:=MA(CLOSE,18);
FF:=VAR3>REF(VAR3,1);PARTLINE(VAR3,FF,RGB(255,0,0),1,RGB(3,3,255)),LINETHICK4;
VAR4:=MA(CLOSE,4);
FF:=VAR4>REF(VAR4,1); PARTLINE(VAR4,FF,RGB(235,1,1),1,RGB(3,3,255)),LINETHICK3;
RSV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
X:=REF(J,1)REF(H,1) AND C>REF(C,1) AND C>REF(O,1) AND L>REF(L,1);
STICKLINE(X,L ,L,20,0),COLOR008888;
STICKLINE(X,L ,H,0,0),COLORFF00FF;
STICKLINE(X,C ,O,5,0),COLORFF00FF;
WR:="W&R"(14);
DRAWICON(FILTER(CROSS(WR,(0 - 81)),10),L,4);//威廉买点↑ ↓
DRAWICON(FILTER(CROSS((0 -19),WR),10),H,5);//威廉卖点
DRAWTEXT(FILTER(CROSS(WR,(0 - 81)),21),L,'威廉买'),ALIGN0,colorred;//威廉买点
DRAWTEXT(FILTER(CROSS(0 -19,WR),21),H,'威廉卖'),ALIGN2,colorgreen;//威廉卖点
aa:=CLOSE > REF(CLOSE, 1) AND REF(CLOSE, 1) > REF(CLOSE, 2) AND REF(CLOSE, 1) <

REF(CLOSE, 3) AND IF(REF(CLOSE, 3) < REF(CLOSE, 4), 1, IF(REF(CLOSE, 4) < REF

(CLOSE, 5),REF(CLOSE, 1) < REF(CLOSE, 4) OR( REF(CLOSE, 2) < REF(CLOSE, 4) AND REF

(CLOSE, 3) >= REF(CLOSE, 5) ),IF(REF(CLOSE, 5) < REF(CLOSE, 6), 1,REF(CLOSE, 6) <

REF(CLOSE, 7))));
bb:=CLOSE < REF(CLOSE, 1) AND REF(CLOSE, 1) < REF(CLOSE, 2) AND REF(CLOSE, 1) >

REF(CLOSE, 3) AND IF(REF(CLOSE, 3) > REF(CLOSE, 4), 1, IF(REF(CLOSE, 4) > REF

(CLOSE, 5),REF(CLOSE, 1) > REF(CLOSE, 4) OR( REF(CLOSE, 2) > REF(CLOSE, 4) AND REF

(CLOSE, 3) <= REF(CLOSE, 5) ),IF(REF(CLOSE, 5) > REF(CLOSE, 6), 1,REF(CLOSE, 6) >

REF(CLOSE, 7))));
DRAWTEXT(aa AND CLOSE>REF(OPEN,2),LOW,'三平底'),color,COLORFF00FF;
DRAWTEXT(bb AND CLOSE S下:=HHV(MA(HIGH,2),2),colorgreen,LINETHICK0;
S上:=LLV(MA(HIGH,2),1),colorred,LINETHICK0;
Sppp:=-(S上-S下)/REF(C,1)*100;
Sptem1:=(MIN(O,C)-L)/(H-L)*100;
Sptem2:=(H-MAX(O,C))/(H-L)*100;
SPTEM3:=(C-O)/(H-L)*100;
SKJ1:=(SPTEM3>49 AND SPTEM1>0.3*SPTEM2) OR SPTEM3>80;
SKJ2:=(SPTEM3<=49 AND SPTEM3>20 AND SPTEM1>SPTEM2);
SKJ3:=(SPTEM3<=20 AND sptem3>-20 AND sptem1>1.2*sptem2);
SKJ4:=(SPTEM3-40 AND SPTEM1>2*SPTEM2);
SKJ:=(SKJ1 OR SKJ2 OR SKJ3 OR SKJ4) AND (Sppp>2 OR REF(Sppp,1)>2 );
短买:=IF(SUM(sppp>0,5)=5 AND SUM(skj>0,5)=0,5*(SKJ1 OR SKJ2 OR SKJ3 OR

SKJ4),5*skj),colorred;
DRAWTEXT(短买,L,'↖短买'),colorwhite;


2.gif

发表于 2018-1-10 15:41 | 显示全部楼层
感谢分享!!!!!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

广告联系|Archiver|手机版|股票吧 ( 粤ICP备05036799号 )

GMT+8, 2018-7-18 20:50 , Processed in 0.097618 second(s), 26 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表