股票吧

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 92123|回复: 145

[大智慧] 大智慧主图公式----操盘手BS操盘线[原码]

  [复制链接]
发表于 2009-3-9 00:40 | 显示全部楼层 |阅读模式
{操盘手BS操盘线(大智慧主图)}

  1. 买线:=EMA(C,2);
  2. 卖线:=EMA(SLOPE(C,21)*20+C,42);   
  3. BU:=cross(买线,卖线);
  4. SEL:=cross(卖线,买线);
  5. drawtext(bu,LOW*0.989,'B'),colorred,linethick3;
  6. DRAWTEXT(bu,LOW,''),Color208FFF,LINETHICK3;
  7. DRAWTEXT(sel,HIGH,''),ColorFFFF00,LINETHICK3;
  8. drawtext(sel,HIGH*1.0175,'S'),colorffff00,linethick3;
  9. stickline(买线>=卖线,low,high,1,0),colorred;
  10. stickline(买线>=卖线,close,open,4.5,0),color0000aa;
  11. stickline(买线>=卖线,close,open,4,0),color0000cc;
  12. stickline(买线>=卖线,close,open,3,0),color0000cc;
  13. stickline(买线>=卖线,close,open,2,0),color0000ee;
  14. stickline(买线<卖线,close,open,4.5,0),coloraaaa00;
  15. stickline(买线<卖线,close,open,4,0),colorbbbb00;
  16. stickline(买线<卖线,close,open,3,0),colorcccc00;
  17. stickline(买线<卖线,close,open,2,0),coloreeee00;
  18. stickline(买线<卖线,low,high,1,0),colorffff00;
  19. stickline(cross(买线,卖线) or cross(卖线,买线),open,close,3,0),color00ffff;
  20. 指导线: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),linethick1,ColorFFffFF;
  21. 界: MA(CLOSE,27),linethick1,Color00FFFF;
  22. DRAWTEXT(cross(指导线,界),界,&#39;&#39;),Colorffffff;
  23. DRAWTEXT(cross(界,指导线),界,&#39;&#39;),Color00ffff;
  24. RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
  25. K:=SMA(RSV,3,1);
  26. D:=SMA(K,3,1);
  27. J:=3*K-2*D;
  28. G:=95;
  29. DRAWTEXT(cross(J,D),L*0.999,&#39;&#39;),Color00ffff,linethick4;
  30. DRAWTEXT(cross(J,D),L,&#39;&#39;),Color00ffff;
  31. DRAWTEXT(cross(J,G),H*1.005,&#39;&#39;),Colorffff00,linethick4;
  32. DRAWTEXT(cross(J,G),H,&#39;&#39;),Colorffff00;
复制代码
 楼主| 发表于 2009-3-9 00:42 | 显示全部楼层
大智慧主图公式----操盘手BS操盘线
ddimage5.jpg
回复 支持 反对

使用道具 举报

发表于 2009-3-9 08:59 | 显示全部楼层
bsbsbs
回复 支持 反对

使用道具 举报

发表于 2009-3-9 14:52 | 显示全部楼层
sssssssssssssssssssssss
回复 支持 反对

使用道具 举报

头像被屏蔽
发表于 2009-3-9 16:29 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
回复 支持 反对

使用道具 举报

发表于 2009-3-9 20:50 | 显示全部楼层
thankyouyes
回复 支持 反对

使用道具 举报

发表于 2009-3-9 21:13 | 显示全部楼层
ma5:ema(c,5),colorwhite;
工作线:ema(c,14),colorf00ff0,linethick1;


二号线:ema(c,25),color00ff00,linethick1;
九号线:eMA(CLOSE,99),linethick1;
MA120:eMA(CLOSE,120),linethick1;
生命线:eMA(CLOSE,453),linethick1,colorred;
DIFF:=( EMA(CLOSE,7) - EMA(CLOSE,19)),COLORwhite;
DEA:=EMA(DIFF,9),COLORf00ff0 ;
MACD:=0.90*(DIFF-DEA), COLORSTICK;
tj:=(diff>=dea);
tj1:=(diff>=0);
stickline(tj,h,l,0.5,0),COLORyellow;
stickline(tj,o,c,4,0),COLORyellow;
stickline(tj1 and tj,h,l,0.5,0),colorf00ff0;
stickline(tj1 and tj,o,c,4,1),colorf00ff0;
stickline(diff<dea,h,l,0.5,0),colorf0f000;
stickline(diff<dea,o,c,4,0),colorf0f000;
Var1:=(CLOSE*2+HIGH+LOW)/4;
SK:= EMA(Var1,13)-EMA(Var1,73);
SD:= EMA(SK,2);
drawtext((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 ) or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)) ,l*0.99,&#39;短线&#39;),colorred;
stickline((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 ) or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)),h,l,0.5,0),colorred;
stickline((cross(sk,sd) and sk<-0.04 and (c-ref(c,1))/ref(c,1)>=0.03) or (cross(sk,sd) and sk<=-0.14 ) or (cross(sk,sd) and sk<=0.05 and (v/ma(v,5)>2 or c/ref(c,1)>0.035)),o,c,6,1),linethick3,colorred;
回复 支持 反对

使用道具 举报

发表于 2009-3-9 22:10 | 显示全部楼层
大智慧主图公式----操盘手BS操盘线[原码]
本部分内容设定了隐藏,需要回复后才能看到
回复 支持 反对

使用道具 举报

发表于 2009-3-15 14:56 | 显示全部楼层
操盘手BS操盘线
回复 支持 反对

使用道具 举报

发表于 2009-3-16 15:59 | 显示全部楼层
支持,下载一下看看
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

广告联系|Archiver|手机版|股票吧 ( 粤ICP备05036799号 )

GMT+8, 2017-6-27 08:14 , Processed in 0.088022 second(s), 26 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表