股票吧

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 212202|回复: 915

[通达信] 通达信主图公式------机构进仓指标(原码)

  [复制链接]
发表于 2008-11-20 22:36 | 显示全部楼层 |阅读模式
机构进仓指标
VAR1:=MA(CLOSE,5),COLOR00FFFF;
VAR6:=MA(CLOSE,54),COLORFF9900;
VAR8:= DMA(EMA(CLOSE,12),SUM(VOL/CAPITAL,5)/3),LINETHICK2;
VARA:=REF(CLOSE,1);
VARE:=SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100;
DRAWTEXT(DATE>700101 AND CROSS(84,VARE),HIGH,'☆机构减仓'),COLORGREEN;
VARF:=(2*CLOSE+HIGH+LOW)/4;
VAR10:=LLV(LOW,23);
VAR11:=HHV(HIGH,23);
VAR12:=EMA((VARF-VAR10)/(VAR11-VAR10)*100,6);
VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,4);
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VAR12>VAR13,3) AND REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),LOW,&#39;★机构进场&#39;),COLORYELLOW;
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
压力位:IF(CROSS(J24,J),H,REF(H,BARSLAST(CROSS(J24,J)))),COLOR00FF33,LINETHICK1;
支撑位:IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24)))),COLORCC33CC,LINETHICK1;
支撑价:LLV(LOW,34) ,COLOR7FFF00,LINETHICK2;
阻力价:HHV(HIGH,19),COLORFF9900, LINETHICK2;
十:MA(C,5),COLOR00FFFF,LINETHICK2;
涨:IF(MA(CLOSE,5)>REF(MA(CLOSE,5),1),MA(CLOSE,5),DRAWNULL),COLORRED,LINETHICK2;
平:IF(MA(CLOSE,5)=REF(MA(CLOSE,5),1),MA(CLOSE,5),DRAWNULL),COLOR00FFFF,LINETHICK3;
跌:IF(MA(CLOSE,5)<REF(MA(CLOSE,5),1),MA(CLOSE,5),DRAWNULL),COLORGREEN,LINETHICK2;
DRAWTEXT(REF(C,BARSLAST(REF(CROSS(\"MACD.DIF\",\"MACD.DEA\"),1))+1)>C AND REF(\"MACD.DIF\",BARSLAST(REF(CROSS(\"MACD.DIF\",\"MACD.DEA\"),1))+1)<\"MACD.DIF\" AND CROSS(\"MACD.DIF\",\"MACD.DEA\")>0,L-0.02,&#39;★M&#39;),COLOR00FFFF;{MACD底背离}
DRAWTEXT(REF(C,BARSLAST(REF(CROSS(\"KDJ.K\",\"KDJ.D\"),1))+1)>C AND REF(\"KDJ.K\",BARSLAST(REF(CROSS(\"KDJ.K\",\"KDJ.D\"),1))+1)<\"KDJ.K\" AND CROSS(\"KDJ.K\",\"KDJ.D\"),L-0.10,&#39;◎K&#39;),COLORFF00FF;{KDJ底背离}
DRAWTEXT(REF(C,BARSLAST(REF(CROSS(\"RSI.RSI1\",\"RSI.RSI2\"),1))+1)>C AND REF(\"RSI.RSI1\",BARSLAST(REF(CROSS(\"RSI.RSI1\",\"RSI.RSI2\"),1))+1)<\"RSI.RSI1\" AND CROSS(\"RSI.RSI1\",\"RSI.RSI2\")>0,L-0.18,&#39;◆R&#39;),COLOR0000FF;{RSI底背离};
DRAWTEXT(REF(C,BARSLAST(REF(CROSS(\"MACD.DEA\",\"MACD.DIF\"),1))+1)<C AND REF(\"MACD.DIF\",BARSLAST(REF(CROSS(\"MACD.DEA\",\"MACD.DIF\"),1))+1)>\"MACD.DIF\" AND CROSS(\"MACD.DEA\",\"MACD.DIF\")>0,H+0.16,&#39;★M&#39;),COLOR00FF00;{MACD顶背离};
DRAWTEXT(REF(C,BARSLAST(REF(CROSS(\"KDJ.D\",\"KDJ.K\"),1))+1)<C AND REF(\"KDJ.K\",BARSLAST(REF(CROSS(\"KDJ.D\",\"KDJ.K\"),1))+1)>\"KDJ.K\" AND CROSS(\"KDJ.D\",\"KDJ.K\")>0,H+0.08,&#39;◎K&#39;),COLORFFFFCC;{KDJ顶背离}
DRAWTEXT(REF(C,BARSLAST(REF(CROSS(\"RSI.RSI2\",\"RSI.RSI1\"),1))+1)<C AND REF(\"RSI.RSI1\",BARSLAST(REF(CROSS(\"RSI.RSI2\",\"RSI.RSI1\"),1))+1)>\"RSI.RSI1\" AND CROSS(\"RSI.RSI2\",\"RSI.RSI1\")>0,H+0.04,&#39;◆R&#39;),COLORFF9900;{RSI顶背离};
发表于 2008-11-20 22:58 | 显示全部楼层
谢谢,我刚好用的:通达信,对于公式还很陌生,下来试试
回复 支持 反对

使用道具 举报

 楼主| 发表于 2008-11-20 23:08 | 显示全部楼层
公式不错,你看一下。。。
回复 支持 反对

使用道具 举报

发表于 2008-11-20 23:33 | 显示全部楼层
看看咯,谢谢楼主的哈
回复 支持 反对

使用道具 举报

发表于 2008-11-21 00:40 | 显示全部楼层
看看咯,谢谢楼主的哈
回复 支持 反对

使用道具 举报

发表于 2008-11-21 07:08 | 显示全部楼层
回复后看看!!
回复 支持 反对

使用道具 举报

发表于 2008-11-21 07:42 | 显示全部楼层
谢谢楼主
回复 支持 反对

使用道具 举报

发表于 2008-11-21 11:10 | 显示全部楼层
谢谢楼主的哈
回复 支持 反对

使用道具 举报

发表于 2008-11-21 12:41 | 显示全部楼层
楼主有这么多好公式供大家分享谢谢了
回复 支持 反对

使用道具 举报

发表于 2008-11-21 12:52 | 显示全部楼层
主有这么多好公式供大家分享谢谢
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

广告联系|Archiver|手机版|股票吧 ( 粤ICP备05036799号 )

GMT+8, 2017-10-21 07:34 , Processed in 0.076687 second(s), 19 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表